• Stefan Strogin's avatar
    http: use new API with LibreSSL >=2.7.0 · d2577d7f
    Stefan Strogin authored
    
    
    LibreSSL is not yet fully API compatible with OpenSSL 1.0.2 and later,
    However many APIs from OpenSSL 1.0.2 and 1.1 are already implemented in
    LibreSSL 2.7.0 and later. Old approach works in newer LibreSSL version
    as well, but it's not nice to force deprecated functions on LibreSSL
    users.
    
    Add additional conditionals for new LibreSSL versions to use the
    available new APIs.
    Signed-off-by: Ralph Giles's avatarRalph Giles <giles@thaumas.net>
    d2577d7f
http.c 129 KB