Commit 03e80211 authored by Tom Finegan's avatar Tom Finegan

Set cmake minimum version to that which is really required.

The use of target_sources in combination with generator expressions
is not supported before v3.5. Set min required version to v3.5.

BUG=https://bugs.chromium.org/p/aomedia/issues/detail?id=76

Change-Id: Ifa1ea25e17ac58d631436c31ab9d4d9231e689f2
parent 677d24bf
......@@ -8,7 +8,7 @@
## Media Patent License 1.0 was not distributed with this source code in the
## PATENTS file, you can obtain it at www.aomedia.org/license/patent.
##
cmake_minimum_required(VERSION 3.2)
cmake_minimum_required(VERSION 3.5)
project(AOM C CXX)
set(AOM_ROOT "${CMAKE_CURRENT_SOURCE_DIR}")
......
......@@ -8,8 +8,6 @@
## Media Patent License 1.0 was not distributed with this source code in the
## PATENTS file, you can obtain it at www.aomedia.org/license/patent.
##
cmake_minimum_required(VERSION 3.2)
include(FindGit)
include(FindPerl)
......
......@@ -8,8 +8,6 @@
## Media Patent License 1.0 was not distributed with this source code in the
## PATENTS file, you can obtain it at www.aomedia.org/license/patent.
##
cmake_minimum_required(VERSION 3.2)
include(CheckCCompilerFlag)
include(CheckCXXCompilerFlag)
......
......@@ -8,8 +8,6 @@
## Media Patent License 1.0 was not distributed with this source code in the
## PATENTS file, you can obtain it at www.aomedia.org/license/patent.
##
cmake_minimum_required(VERSION 3.2)
include(CheckCSourceCompiles)
include(CheckCXXSourceCompiles)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment