Commit 5908e0b6 authored by James Zern's avatar James Zern
Browse files

vs/armv7: use -oldit armasm flag

this quiets warnings from armv6 code [1].
from msdn [2]:
-oldit
Generate ARMv7-style IT blocks. By default, ARMv8-compatible IT blocks
are generated.

a new configuration would be needed for armv8 in any case as the neon
assembly is being built, so removing this should be harmless

[1] A4509: This form of conditional instruction is deprecated
[2] https://msdn.microsoft.com/en-us/library/hh873189.aspx

Change-Id: I4c3b838b52a87401c6daecd83d22ab148ed7c5d9
parent 9c6eea35
......@@ -263,8 +263,8 @@ case "$target" in
;;
arm*)
platforms[0]="ARM"
asm_Debug_cmdline="armasm -nologo "%(FullPath)""
asm_Release_cmdline="armasm -nologo "%(FullPath)""
asm_Debug_cmdline="armasm -nologo -oldit "%(FullPath)""
asm_Release_cmdline="armasm -nologo -oldit "%(FullPath)""
;;
*) die "Unsupported target $target!"
;;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment