Commit caca1355 authored by Monty Montgomery's avatar Monty Montgomery Committed by Christopher Montgomery

Add proper CMAKE dependencies for CONFIG_DAALA_DCT4 experiment

CONFIG_DAALA_DCT8 added the necessary related configuration
enable/disable logic to the CMAKE build to be consistent with the
Automake build system, but the earlier CONFIG_DAALA_DCT4 commits did
not.  This brings CONFIG_DAALA_DCT4 up to date and consistent with
DCT8.

Change-Id: Iba9fda00c251f5477fdb4c35fc5cd8874050b530
parent 7346ca19
......@@ -243,30 +243,38 @@ if (CONFIG_VAR_TX_NO_TX_MODE AND NOT CONFIG_VAR_TX)
set(CONFIG_VAR_TX_NO_TX_MODE 0)
endif()
if (CONFIG_DAALA_DCT8)
if (CONFIG_DAALA_DCT4)
if (NOT CONFIG_DCT_ONLY)
message(WARNING
"--- Enabled CONFIG_DCT_ONLY, needed for CONFIG_DAALA_DCT4.")
set(CONFIG_DCT_ONLY 1)
endif()
endif()
if (CONFIG_DAALA_DCT4 OR CONFIG_DAALA_DCT8)
if (HAVE_MMX)
message(WARNING
"--- Disabled HAVE_MMX, required for CONFIG_DAALA_DCT8.")
"--- Disabled HAVE_MMX, incompatible with CONFIG_DAALA_DCTx.")
set(HAVE_MMX 0)
endif()
if (CONFIG_RECT_TX)
message(WARNING
"--- Disabled CONFIG_RECT_TX, required for CONFIG_DAALA_DCT8.")
"--- Disabled CONFIG_RECT_TX, incompatible with CONFIG_DAALA_DCTx.")
set(CONFIG_RECT_TX 0)
endif()
if (CONFIG_VAR_TX)
message(WARNING
"--- Disabled CONFIG_VAR_TX, required for CONFIG_DAALA_DCT8.")
"--- Disabled CONFIG_VAR_TX, incompatible with CONFIG_DAALA_DCTx.")
set(CONFIG_VAR_TX 0)
endif()
if (CONFIG_LGT)
message(WARNING
"--- Disabled CONFIG_LGT, required for CONFIG_DAALA_DCT8.")
"--- Disabled CONFIG_LGT, incompatible with CONFIG_DAALA_DCTx.")
set(CONFIG_LGT 0)
endif()
if (NOT CONFIG_LOWBITDEPTH)
message(WARNING
"--- Enabled CONFIG_LOWBITDEPTH, required for CONFIG_DAALA_DCT8.")
"--- Enabled CONFIG_LOWBITDEPTH, needed for CONFIG_DAALA_DCTx.")
set(CONFIG_LOWBITDEPTH 1)
endif()
endif()
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment