Commit 89ac5f37 authored by moritz's avatar moritz

Do not rely on a succesful pkg-config(1) check for libshout2, as there are

still some systems where only shout-config gets installed (NetBSD for example.)


git-svn-id: https://svn.xiph.org/trunk/ezstream@16377 0101bb08-14d6-0310-b084-bc0e0c8e3800
parent 22e82f0c
......@@ -148,9 +148,11 @@ if test -z "${PKG_CONFIG}"; then
AC_MSG_ERROR([The pkg-config utility is required.], [1])
fi
dnl ####### BEGIN CHECK ######
PKG_CHECK_EXISTS([shout $1], [
dnl ##########################
if test -n "$1" -a x"${ax_check_libshout_shout_pc}" = "xyes"; then
PKG_CHECK_EXISTS([shout $1], [],
[AC_MSG_ERROR([libshout version $1 is required.], [1])]
)
fi
libshout_libs_autodetect=no
if test -z "${LIBSHOUT_LIBS}"; then
......@@ -202,10 +204,6 @@ LDFLAGS="${ax_check_libshout_save_LDFLAGS}"
LIBS="${ax_check_libshout_save_LIBS}"
AC_LANG_POP([C])
dnl ####### END CHECK ########
], [])
dnl ##########################
fi # want_libshout != no
])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment