Commit 1e4b6699 authored by Jan Gerber's avatar Jan Gerber
Browse files

switch to ffmpeg 0.6 branch

parent c0f22811
FFMPEG_REVISION=23009
FFMPEG_CO_DIR=ffmpeg FFMPEG_CO_DIR=ffmpeg
FFMPEG_SVN=svn://svn.ffmpeg.org/ffmpeg/trunk FFMPEG_SVN=svn://svn.ffmpeg.org/ffmpeg/branches/0.6
#not required fro 0.6 branch
# Because ffmpeg checks out libswscale via an svn:externals, checking # Because ffmpeg checks out libswscale via an svn:externals, checking
# out an old ffmpeg does not check out a corresponding libswscale. # out an old ffmpeg does not check out a corresponding libswscale.
# Keep the swscale checkout manually synchronized, then. Update this # Keep the swscale checkout manually synchronized, then. Update this
# when you update FFMPEG_REVISION. # when you update FFMPEG_REVISION.
FFMPEG_EXTERNALS_REVISION=31128 #FFMPEG_REVISION=23309
#FFMPEG_EXTERNALS_REVISION=31211
#!/bin/sh #!/bin/sh
common="--enable-version3 --enable-gpl --enable-postproc --disable-muxers --disable-encoders --enable-libvorbis" common="--enable-version3 --enable-gpl --enable-postproc --disable-muxers --disable-encoders --enable-libvorbis"
common="$common --disable-ffmpeg --disable-ffplay --disable-ffserver --disable-doc" common="$common --disable-ffmpeg --disable-ffplay --disable-ffserver --disable-ffprobe --disable-doc"
#optional, if you have those libs installed: #optional, if you have those libs installed:
#extra="--enable-libopencore-amrnb --enable-libopencore-amrwb" #extra="--enable-libopencore-amrnb --enable-libopencore-amrwb"
...@@ -9,6 +9,9 @@ common="$common --disable-ffmpeg --disable-ffplay --disable-ffserver --disable-d ...@@ -9,6 +9,9 @@ common="$common --disable-ffmpeg --disable-ffplay --disable-ffserver --disable-d
#apt-get install liba52-dev libfaad-dev libgsm1-dev #apt-get install liba52-dev libfaad-dev libgsm1-dev
#extra="$extra--enable-libfaad --enable-libgsm" #extra="$extra--enable-libfaad --enable-libgsm"
#optional, if you have libvpx installed:
#extra="--enable-libvpx"
#linux #linux
options="$common --enable-pthreads $extra" options="$common --enable-pthreads $extra"
...@@ -19,8 +22,11 @@ uname | grep MINGW && options="$common --enable-memalign-hack --enable-mingw32 - ...@@ -19,8 +22,11 @@ uname | grep MINGW && options="$common --enable-memalign-hack --enable-mingw32 -
. ./ffmpegrev . ./ffmpegrev
#Get ffmpeg from svn #Get ffmpeg from svn
svn -r $FFMPEG_REVISION co $FFMPEG_SVN $FFMPEG_CO_DIR #svn -r $FFMPEG_REVISION co $FFMPEG_SVN $FFMPEG_CO_DIR
svn update -r $FFMPEG_EXTERNALS_REVISION $FFMPEG_CO_DIR/libswscale #svn update -r $FFMPEG_EXTERNALS_REVISION $FFMPEG_CO_DIR/libswscale
#Get ffmpeg from svn 0.6 branch
svn co $FFMPEG_SVN $FFMPEG_CO_DIR
apply_patches() { apply_patches() {
cd ffmpeg cd ffmpeg
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment