Commit 682e5e40 authored by Jan Gerber's avatar Jan Gerber
Browse files

switch back to ffmpeg 0.5 branch, a/v issues not solved in trunk

parent b21ab23a
svn
- fix input from codecs with visible vs. encoded width
- update ffmpeg to fix a/v sync issues in some mov/mp4 files
0.24 2009-03-12
- fix to make --max_size --no_upscaling work
......
......@@ -128,11 +128,10 @@ if not conf.CheckPKG(FFMPEG_LIBS):
for lib in FFMPEG_LIBS.split():
ParsePKGConfig(env, lib)
#FIXME: this no longer works with ffmpeg trunk
#if conf.CheckCHeader('libavformat/framehook.h'):
# env.Append(CCFLAGS=[
# '-DHAVE_FRAMEHOOK'
# ])
if conf.CheckCHeader('libavformat/framehook.h'):
env.Append(CCFLAGS=[
'-DHAVE_FRAMEHOOK'
])
KATE_LIBS="oggkate"
if os.path.exists("./libkate/misc/pkgconfig"):
......
FFMPEG_REVISION=18071
FFMPEG_REVISION=17942
FFMPEG_CO_DIR=ffmpeg
FFMPEG_SVN=svn://svn.ffmpeg.org/ffmpeg/trunk
FFMPEG_SVN=svn://svn.ffmpeg.org/ffmpeg/branches/0.5
# Because ffmpeg checks out libswscale via an svn:externals, checking
# out an old ffmpeg does not check out a corresponding libswscale.
# Keep the swscale checkout manually synchronized, then. Update this
# when you update FFMPEG_REVISION.
FFMPEG_EXTERNALS_REVISION=29008
FFMPEG_EXTERNALS_REVISION=28777
......@@ -7,7 +7,7 @@
#apt-get install liba52-dev libfaad-dev libgsm1-dev
#extra=" --enable-libfaad --enable-libgsm"
common="--enable-gpl --enable-postproc --disable-encoders --enable-libvorbis"
common="--enable-gpl --enable-swscale --enable-postproc --disable-encoders --enable-libvorbis"
#linux
options="$common --enable-pthreads $extra"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment