Commit 2860f178 authored by Erik de Castro Lopo's avatar Erik de Castro Lopo
Browse files

configure.ac : If gcc is version 4.2, use -fgnu89-inline.

Using -gnu-inline avoids a rather ugly warning message that only
seems to be present with gcc-4.2.
parent cd3162a2
......@@ -360,14 +360,18 @@ if test x$ac_cv_c_compiler_gnu = xyes ; then
if test x$enable_gcc_werror = "xyes" ; then
CFLAGS="-Wall -Wextra -Werror $CFLAGS"
CXXFLAGS="-Wall -Wextra -Werror $CXXFLAGS"
fi
fi
if test "$GCC_MAJOR_VERSION" -ge 4 && test "$OBJ_FORMAT" = elf; then
CPPFLAGS="$CPPFLAGS -DFLAC__USE_VISIBILITY_ATTR"
CFLAGS="$CFLAGS -fvisibility=hidden"
CXXFLAGS="$CXXFLAGS -fvisibility=hidden"
fi
if test "x$GCC_MAJOR_VERSION$GCC_MINOR_VERSION" = "x42" ; then
XIPH_ADD_CFLAGS([-fgnu89-inline])
fi
fi
fi
XIPH_ADD_CFLAGS([-Wextra])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment