Commit 5f18d370 authored by giles's avatar giles

Update autogen.sh to look for automake 1.8 and 1.9, and to use the

versioned versions if appropriate.


git-svn-id: http://svn.annodex.net/liboggz/trunk@2373 8158c8cd-e7e1-0310-9fa4-c5954c97daef
parent 94b328c7
......@@ -41,7 +41,11 @@ fi
#
automake_version="none"
if automake-1.7 --version >/dev/null 2>&1; then
if automake-1.9 --version >/dev/null 2>&1; then
automake_version="-1.9"
elif automake-1.8 --version >/dev/null 2>&1; then
automake_version="-1.8"
elif automake-1.7 --version >/dev/null 2>&1; then
automake_version="-1.7"
elif automake-1.6 --version >/dev/null 2>&1; then
automake_version="-1.6"
......@@ -74,6 +78,8 @@ if test "$automake_version_major" -lt "5"; then
exit 1
fi
AUTOMAKE="automake${automake_version}"
ACLOCAL="aclocal${automake_version}"
#
# do we need pkg-config?
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment