Commit 66c79841 authored by Pino Toscano's avatar Pino Toscano Committed by conrad

Debian #557537: FTBFS on hurd-i386: wrong platform detection for version

script

The problem is the condition used in the configure script for choosing whether
use a version script or not:
  case "$target_os" in
    linux* | solaris*|k*bsd*-gnu*|gnu-*)
given $target_os is "gnu0.3" for GNU/Hurd, the condition is not valid
for it.
Signed-off-by: conrad's avatarConrad Parker <conrad@metadecks.org>
parent 26c5d2f2
......@@ -401,7 +401,7 @@ dnl Shared library symbol versioning and hiding
dnl
case "$target_os" in
linux* | solaris*|k*bsd*-gnu*|gnu-*)
linux* | solaris*|k*bsd*-gnu*|gnu*)
SHLIB_VERSION_ARG="-Wl,--version-script=Version_script"
;;
*)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment