Commit dc8ce7f1 authored by andre's avatar andre

andre: added pkg-config detection support to autogoat, err, i mean autogen.sh


git-svn-id: http://svn.annodex.net/liboggz/trunk@368 8158c8cd-e7e1-0310-9fa4-c5954c97daef
parent bb072d30
......@@ -35,6 +35,7 @@ if test "x$1" = "xclean"; then
fi
#
# check automake version number -- we require >= 1.5
#
......@@ -74,6 +75,30 @@ if test "$automake_version_major" -lt "5"; then
fi
#
# do we need pkg-config?
#
if grep -q PKG_CHECK_MODULES configure.*; then
if ! which pkg-config > /dev/null 2> /dev/null; then
cat << EOF
$0: pkg-config is required, but it's not installed or can't be found in your
search path.
EOF
# be nice to the user if they have fink!
if test -d /sw ; then
cat << EOF
You can install it via Fink with the command
apt-get install pkgconfig
EOF
fi
fi
fi
#
# autogoat bootstrap process
#
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment