Verified Commit d2577d7f authored by Stefan Strogin's avatar Stefan Strogin Committed by Ralph Giles

http: use new API with LibreSSL >=2.7.0

LibreSSL is not yet fully API compatible with OpenSSL 1.0.2 and later,
However many APIs from OpenSSL 1.0.2 and 1.1 are already implemented in
LibreSSL 2.7.0 and later. Old approach works in newer LibreSSL version
as well, but it's not nice to force deprecated functions on LibreSSL
users.

Add additional conditionals for new LibreSSL versions to use the
available new APIs.
Signed-off-by: Ralph Giles's avatarRalph Giles <giles@thaumas.net>
parent d59a17ec
Pipeline #497 passed with stage