Commit c5bb7722 authored by Monty Montgomery's avatar Monty Montgomery

Makefile change; gtk2.4 randomly decided to deprecate GtkOptionMenu,

so I have to eliminate all the 'don't use deprecated features!'
defines to keep everyone's builds from exploding.



git-svn-id: https://svn.xiph.org/trunk/postfish@6781 0101bb08-14d6-0310-b084-bc0e0c8e3800
parent ba9f5026
......@@ -36,7 +36,8 @@ OBJ = main.o mainpanel.o multibar.o readout.o input.o output.o clippanel.o \
bessel.o suppresspanel.o suppress.o singlecomp.o singlepanel.o \
limit.o limitpanel.o mute.o mixpanel.o mix.o reverb.o reverbpanel.o \
outpanel.o config.o
GCF = -DETCDIR=\\\"$(ETCDIR)\\\" `pkg-config --cflags gtk+-2.0` -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED
#GCF = -DETCDIR=\\\"$(ETCDIR)\\\" `pkg-config --cflags gtk+-2.0` -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED
GCF = -DETCDIR=\\\"$(ETCDIR)\\\" `pkg-config --cflags gtk+-2.0`
all:
$(MAKE) target CFLAGS="-O3 -ffast-math -fomit-frame-pointer $(GCF) $(ADD_DEF)"
......
#define VERSION "$Id$ "
/* DO NOT EDIT: Automated versioning hack [Sat May 29 02:18:36 EDT 2004] */
/* DO NOT EDIT: Automated versioning hack [Sat May 29 07:51:35 EDT 2004] */
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment