Commit 4ee682f5 authored by Jean-Marc Valin's avatar Jean-Marc Valin

Bump version number to 1.0.1 and set libtool version

parent 88c499c9
......@@ -21,6 +21,7 @@ include silk_headers.mk
include opus_headers.mk
libopus_la_SOURCES = $(CELT_SOURCES) $(SILK_SOURCES) $(OPUS_SOURCES)
libopus_la_LDFLAGS = -no-undefined -version-info 2:0:2
pkginclude_HEADERS = include/opus.h include/opus_multistream.h include/opus_types.h include/opus_defines.h
......
......@@ -20,7 +20,7 @@ CFLAGS := -Drestrict= $(CFLAGS)
###################### END OF OPTIONS ######################
CFLAGS += -DOPUS_VERSION='"0.9.14"'
CFLAGS += -DOPUS_VERSION='"1.0.1-rc"'
include silk_sources.mk
include celt_sources.mk
include opus_sources.mk
......
......@@ -7,10 +7,10 @@ AM_CONFIG_HEADER([config.h])
dnl enable silent rules on automake 1.11 and later
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
OPUS_MAJOR_VERSION=0
OPUS_MINOR_VERSION=9
OPUS_MICRO_VERSION=14
OPUS_EXTRA_VERSION=
OPUS_MAJOR_VERSION=1
OPUS_MINOR_VERSION=0
OPUS_MICRO_VERSION=1
OPUS_EXTRA_VERSION=-rc
OPUS_VERSION="$OPUS_MAJOR_VERSION.$OPUS_MINOR_VERSION.$OPUS_MICRO_VERSION$OPUS_EXTRA_VERSION"
AC_MSG_CHECKING([git revision])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment